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SOS Appointment Scheduler

Overview
The SOS Appointment Scheduler module is an add-on for SOS Office Manager for
Windows (OMWin) or SOS Case Manager for Windows (CMWin). It provides
full-featured time scheduling for service providers and resources, such as treatment
rooms or equipment. Each appointment can optionally specify the site, making the
system a good choice for organizations in which providers schedule appointments at
different service locations.

w The schedule may be viewed as a single day, a single week, or a six week period.
Multiple views and provider schedules may be open simultaneously.

w A very powerful search feature allows searches on any combination of date range,
time range, patient, day of the week, provider, appointment type, service, site,
resource, and appointment status. Search queries may be named and saved for
quick and easy re-use.

w Customizable routing/encounter forms may be generated for scheduled appoint-
ments. 

w Selected appointments may be imported directly into OMWin’s Daysheet for
billing.

In this manual, we will use the term provider to indicate the person for whom
appointments or scheduled activities are being created. Other staff may take
advantage of the Scheduler features as well by adding their names to the Provider List
in OMWin.

Starting the Scheduler

Start the scheduler
from the main menu in
either SOS Office
Manager or SOS Case
Manager.

The Scheduler should appear as a top level menu item in both SOS Office Manager
(OMWin) and SOS Case Manager (CMWin). Just select this menu item to launch the
program. Once it has been started, the Scheduler runs as an independent program.
You will see it displayed as a button on the Windows “Start” bar and you can switch
back and forth between it and your other applications. Once the Scheduler has been
launched, you can close the main SOS application and continue to use the Scheduler.
When you are finished with the Scheduler, exit just as you would any other program,
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by clicking the “X” in the upper right corner, by pressing <Alt>-<F4> or by selecting
View > Exit.

Setting up the System

Scheduler User Options

Setting Color Preferences

The scheduler is highly dependent upon color coding, which is used in to denote:
w Open appointment slots
w Time periods that are “blocked” and should not be scheduled (vacations, etc.)
w Slots with scheduled appointments
w Times with no appointment slots
w Appointments of different types
w The time column in the display
w Schedule warnings/reminders
w Month View days with no appointment times
w Month View days with open appointment times

You may change the default colors used by the Scheduler. In fact, every user can
select his or her own colors. Configure the colors to your liking by selecting Setup >
Scheduler Options. Set your own preferred colors on the User Colors tabs of this
form. Remember that your color choices are used only when you have logged into the
main SOS application with the same ID used when making the settings. Notice that the
current user ID is displayed in the title bar at the top of the Scheduler Options
window.

The first three tabs of
this form allow you to
set your preferred
colors for various
scheduler elements

SOS Appointment Scheduler

- Page 6 -



Scheduler System Options

To set scheduler system options (as opposed to user options), select Setup >
Scheduler Options, then the System Options tab. There are several system options
that you should set on this window:

Work Day Start and End Times

The Work Day Start and Work Day End times should be set to the earliest and latest
times that you expect to ever schedule an appointment. These times control the range
of times that appear in your Day and Week View windows and the times available to
select when creating an appointment.

Required Fields

If appropriate for your organization, you may want to require that the Resource (see
page 8) or Site (see page 8) field, or both, be completed prior to saving a new
appointment. Any organization in which treatment rooms are limited and shared
among providers should consider listing all the shared rooms in the resource list and
making the Resource field required. Doing so will prevent users from making
appointments for providers without also reserving a treatment room at the same time.

Note that resources and sites can be defaulted in each provider’s appointment
templates (see page 8). If some providers always use the same room (or other
scheduled resource), it can be specified in the providers’ templates, making it the
default when entering new appointments for that provider.

Sites can be handled the same way. If tracking appointments by site is important to
your organization, consider making the appointment Site field required. As with
resource, you can specify the default site for each provider in the templates.

Custom Periods

When doing appointment queries (searches based on selections that you provide),
you can save some time by predefining certain time periods within which you might
like to search. Such as defining Period I as 9AM through noon, Period II as 1PM
through 5PM, and Period III as 7PM through 10PM. Doing so would make it easier to
search for appointments in the morning (Period I), afternoon (Period II) or evening
(Period III). You might want to come back to these settings after using the query
feature for a while.

Providers, Patients, and Services

While creating appointments, you will be selecting from lists of providers, patients,
and services. These are versions of the same lists used in OMWin and CMWin,
except that you cannot add to or modify those lists from within the Scheduler
module. Refer to your OMWin or CMWin documentation if you need information on
adding, deleting, or modifying information in these lists. The differences between the

SOS Appointment Scheduler
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lists as they appear in OMWin and as they appear within the scheduler are detailed in
the following sections.

Configuring the Provider List for use in the Scheduler

If desired, it is possible to filter the provider display in the Scheduler to only those
provider codes that you actually use in this program. 

From OMWin or CMWin, go to Lookups > Providers. Highlight a provider code that
you do want to display within the Scheduler. Click Change. When the form opens,
select the Scheduler tab.

To display the provider within the scheduler, check the  Show this provider code in
Scheduler option. To suppress this code in the Scheduler’s Provider List, uncheck the
option. 

Some OMWin and CMWin users use two or more alternate codes for a single
provider. When scheduling, of course, it is important to use only one of these codes
to avoid double-scheduling the same provider. For example, let’s say that provider
Albert Baines appears in the provider list as AB, AB1, and AB2. You would not want
to accidentally schedule a 9am appointment for both AB and AB1. To prevent any
accidents, it would be a good idea to uncheck Show this provider code in Scheduler
for both AB1 and AB2. Just below this option is a field with the prompt Provider code
used in Appointment Scheduler. Here you would select code AB for all three of
Albert’s codes. 

Note By setting each provider in this fashion, you will be able to select a “billing provider”
from among all of the scheduled provider’s alternate codes (in this example: AB,
AB1, and AB2) when creating appointments that you will subsequently be importing
into an OMWin daysheet. The imported appointments will generate charge entries
with the appointment’s Billing Provider as the Provider on the charge.

Scheduler-specific Lists

Prior to entering any appointments, however, you must set up several other lists that
are specific to the Scheduler module: Appointment Types, Resources, and Sites.

Appointment Types

When you enter an appointment you must indicate an appropriate appointment type.
Appointment types assist in locating appropriate open appointment times, make
entering appointments faster, and designate which appointments should be selected
for Check-in List printouts, for export to OMWin daysheets for billing, and to generate
encounter forms. 

At minimum you will probably want to set up two appointment types: one for patient
appointments and another for personal appointments. You might very well want to
create a type for staff meetings, paperwork, and other types of activities as well.

One significant benefit of appointment types is that each includes a default duration
and therefore can generally eliminate the need for you to manually enter an ending
time for your appointments. If a certain type of appointment is set to a duration of 45
minutes, then the Scheduler will automatically set the ending time for an appointment

SOS Appointment Scheduler
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of that type to 45 minutes after the designated starting time. You can override this
time, of course, but creation of a sufficient selection of appointment types should
make this step unnecessary.

To create your Appointment Types, select Lookups > Appointment Types.  

A good assortment of
appointment types can
enhance the useful-
ness of the Scheduler
and make appoint-
ment entry more
efficient.

Remember that each user can set distinctive colors to signify different appointment
types. Doing so will help you avoid over-scheduling a particular type of service. To
set color preferences for appointment types, click the Set Colors button at the bottom
of the Appointment Type form or go to Setup > Scheduler Options > Appt Types.

IMPORTANT: Durations for each appointment type must always be a multiple of the
minimum appointment time of 15 minutes.

Resources

Resources refer to something that is scheduled in addition to a provider and patient or
client. For example, in some settings providers share treatment rooms. You would
therefore create a resource item for each shared treatment room and designate the
room to be used as you make appointments. The Scheduler will then be able to
prevent room conflicts and you will be able to display appointments by room as well
as by provider. 

To create Resources, select Lookups > Resources. Enter a shorthand code and
description for each and indicate whether Scheduler should:

w Allow the resource to be simultaneously allocated to more than one provider, 

w Warn if it is already allocated to another provider, or 

w Prevent simultaneous use by  more than one provider.

Sites

Organizations with more than one service location may want to designate sites while
making appointments. 

To create sites, select Lookups > Sites. 

SOS Appointment Scheduler
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Provider Appointment Templates

The next step is to set up daily Appointment Templates for each provider for each
work day.  The templates determine the appointment time periods that the provider is
normally available for scheduling and how many simultaneous appointments should
be permitted at various times of the day.  

Each template you enter contains the configuration for each day of the week and is
effective as of the beginning (Sunday) of any week you select. For example, you could
create a template for Dr. Smith that becomes effective on Sunday, January 5, 2003. This
template specifies that Dr. Smith has single appointments available from 9AM though
noon, and 1PM through 6PM on Mondays, Tuesdays, Wednesdays, and Thursdays,
and group times that permit up to eight simultaneous appointments to be scheduled
on Tuesday and Wednesday evenings from 7:30 through 9:00. All other days and
times would be set to permit no appointments.

Attempts to schedule an appointment in a time that is not “templated” will result in a
message asking whether you want to create an exception appointment. Likewise, if
you try to schedule a second appointment in a period that permits only single
appointments, the same sort of message will appear.

Continuing with our example, let’s say that Dr. Smith decides to add a new treatment
group on Thursday night, starting the first Thurday of March. We would use the
Copy Week To... button on the Appointment Templates list window to create a new
template for Dr. Smith, starting the week of  March 2, in which we modify the times on
Thurday evening to permit eight simultaneous appointments between 7:30 and 9:00. 

The templates provide the system with the information needed to find open
appointment times when you use the Query feature. Times that permit appointments,
but are not already filled, will show as available. To create a template:

1. Select Lookups > Templates.

2. Select a provider at the top of the list box window. If this is the provider’s first
template, the list will be empty. Othewise, any existing templates will be displayed
and the template window will look something like this:

Templates determine
the normal scheduling
periods for each
provider on each day
of the week.

SOS Appointment Scheduler
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3. Select Add New Week. Complete the day of the week and time fields and indicate
the number of appointments permitted during that time period. Include a default
Site and Resource if desired. Finally select OK to save. This action will create a
new template and set the first templated day and period. 

Double click other time periods you would like to configure for this day of the
week. If you make a mistake or would like to change the number of appointments
during a period, you can just re-enter the time period with the correct number of
appointments. To remove appointment times, simply reset them with a maximum
appointment setting of zero for that time period. 

To modify the number of appointments in a particular time period of a day,
double-click the beginning of the period you wish to change, then set the times and
number of appointments. For example, if you previously set the period from 9AM
through 5PM to allow one appointment, but want to modify the template to have zero
appointments during the noon lunch hour:

1. Double-click the 12:00 - 12:15 cell on the desired day. The form will appear.

2. Set the Start Time  to 12:00PM and the End Time  to 1:00PM.

3. Set the Number of appointments permitted to zero.

4. OK to save. The previous setting for this time period will be over-written with the
new zero appointments setting.

It is not necessary to manually create templates for every day of the week. If your
available appointment times are the same for other days, you can simply copy the
templates from the first day to the others that are the same, as follows: 

1. Select the Copy Template Day To... button. 

2. In the drop list, select the day that you would like to copy .

3. Check the boxes next to the days to which you want to copy the first day.

4. Click OK.

Entering Appointments

New appointments are entered from the Day View or Week View. The toolbar icon on
the left above opens the Day View, and the one on the right opens the Week View.
Alternately, select View > Day View or View > Week View on the Scheduler menu.

TIP Once the selected view window is open you can stretch it horizontally or vertically
with your mouse to see more appointments without scrolling. Position the mouse on
the edge of the window. The pointer will change to a double-headed arrow. Click and
hold the left mouse button and “drag” the edge of the window as desired. 

1. Select the desired provider.

SOS Appointment Scheduler
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2. Notice that the times available for appointments specified in this provider’s
template are shown in a contrasting color. (The specific color will depend on your
User Setup options.)

3. Select the desired date, using the controls in the Appointment Date panel in the
upper right hand corner of the view window. Click the large button at the top, the
one that shows the current day or week, to select a day or week from a pop-up
calendar window, or use the “VCR” buttons on the second row to move forward
or back  a week (> or <) or a month (>> or <<) at a time.

3. Highlight the desired starting time (within the time slots you have scheduled for
this provider) by clicking with your mouse.

4. Right-click, select the Menu button, or press <F2> to pop up the menu. 

5. Select Add Appointment.

TIP Another way to create a new appointment is to double-click an empty cell in the
appointment grid.

This is the appoint-
ment window. You
must complete all the
red fields in order to
save the appointment.

6. Complete all required (red) fields and add any other desired information. Note that
the Resource and Site fields are on the second (Optional Info) tab, and there is an
area for free text notes on the Remarks tab. Service Code on the first tab is
required only when you are selecting a patient from the Active Patients List. 

Normally when you first create an appointment, you will set the status to the
default, Active. If your office typically confirms appointments the day before, you
can use the Appointment Check-In List with Phone Numbers and Status report
to tell you which appointments are Active, but not confirmed. When you have
confirmed the appointment, change its status to Confirmed by editing the
appointment in the provider's schedule. 

Making an Appointment Outside Normal Hours

You are not limited to the times within your provider templates. If the need should
arise, you can create an appointment outside normal hours. Begin just as with any new
appointment. A warning will appear to tell you that there are no available
appointments, but you may continue anyway. 

SOS Appointment Scheduler
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Adding a Second Appointment to the Same Time Slot

If the selected appointment time permits more than one appointment, you can
schedule additional patients or other activities in the same time period. If the template
is not configured to permit additional appointments in that time slot, you can still add
them,  by continuing after the warning appears. 

Searching for Appointments
One of the scheduler’s most powerful features is the ability to search through your
appointments and present you with a list of those meeting your specified criteria. To
use the search and query feature, select Search Appointments on the pop-up menu
in the Day or Week View. Remember that you can display the pop-up menu by either
right-clicking in the appointment grid, or, after clicking in the grid to activate it, click
the Menu button at the top of the window. One common use of the search window is
to find available appointments on the days and times that the patient can come in.

From here you can
quickly run a previ-
ously saved search
(“query”) or specify a
new one.

To create a new query, click the New Query button. Once you have saved one or more
queries, you can run a query immediately by highlighting the item and clicking Run
Query, or view and modify the query before running it by selecting Edit Query.

The Query form has three tabs. Use the first two to set your selections and the third to
assign a name to your query if you want to save it for future use.

SOS Appointment Scheduler
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First Search Tab

Use this window to
define your search
parameters. This
example shows how
you would search for
open Tuesday morning
appointments with
provider SK during the
next 60 days.

Date Range

You can select a specific date range or use the drop list to select relative ranges in the
future, including: Today, Next 7 days, Next 14 days, Next 30 days, Next 60 days, Next
90 days, or Next 120 days. If you want to do a search including all dates, specify a date
range yourself, such as 1/1/1980 through 12/31/2025.

Time Range

To search all times, just leave the time selection blank. If you are looking for
appointments within a specific time period, set the time period here. For example, you
might have a patient who needs an appointment between 4:30 and 6:00PM, so you
would select those times here. Use the droplist to the left of the time entry fields to
select from pre-configured time periods, such as “Mornings”, “Afternoons”, and
“Evenings”.

Days of the Week

Continuing with our example, let’s say that the patient can only come in on Tuesday,
Wednesday or Friday. We would then check those days of the week in the panel on
the lower left of the window. If our query does not need to be restricted to certain
days of the week, just leave all the days unchecked; it is not necessary to check every
day.

Provider

To specify one or more providers for your query, click the button next to Provider.
Click to tag/untag providers on the list. If you want to query all providers, use this
button to clear the default provider selection.
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Status

One of the primary uses of this feature is to find open appointment times into which a
patient can be booked. Use the Status button to select OPEN or any other listed
status. You can select more than one, if appropriate for your search.

Site

If you want to restrict the results to appointments at a specific site or sites, use this
button to select one or more sites. To include all sites, do not make a selection or clear
any selections that may already be present.

Second Search Tab

Second tab of the
query form

Patient

Use the Select button to choose a particular patient from your active patient list. Use
the Clear Pt button to remove a patient selection. If you are searching for
appointments with a manually entered description, type it in the entry field below the
Select button.

Appointment Types, Services, Resources

Use the remaining buttons on this tab to restrict your search to one or more
appointment types, services, and/or resources.

Completing Your Query

To review your query, select the Show Query button. If this is a one-time query that
you do not want to save for future use, or you have already saved it, run your query
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by clicking the Run Query button. To save the query so it will appear in the query list
and can be easily run again in the future, select Save Query. If you have not already
specified a name for the query on the third tab, the form will advance there. Enter an
appropriate name and click Save Query again.

The scheduler will display the results of the query. To view the schedule for any of
the days that come up in the results, highlight the desired appointment time and click
the button that corresponds to the view your prefer: Day, Week, or Month.

Query Examples

When is my next appointment? Set the Date Range you want to search, select the
Patient, then Run Query.

Does Dr. Smith have any openings on Tuesday afternoon in the next few weeks? Set
your Date Range for the next month, set your Time Range to 12:00PM through
5:00PM, set your Provider to Dr. Smith, and set your Status to OPEN. Select Run
Query.

I would really like to come in today. Does anyone have an opening this morning?
Confirm that the Date Range is set to today, set the Time Range to 8:00AM through
11:45PM, make sure that no Provider is selected, and set Status to OPEN. Select Run
Query.

TIP These sorts of queries are likely to be run very frequently. You can make the process
much faster by creating and saving an “almost-complete” query. When you want to
run that particular search, highlight it and click Edit Query, add the one or two pieces
of additional, specific information, then click Run Query. For example, create a query
that specifies a date period of “Next 60 days” and a status of “Open”, then save it as
“Open appointments, next 60 days”. Next time you need a list of open appointments
for a particular provider, highlight that query, click Edit Query, set the desired
provider, and click Run Query.  

Another common example: “When is my next appointment?”  Create a query that
specifies “Next 120 days” for the date range, and a status of “Active” and save with a
name like “Find patient’s next appointments.” When it comes time to do this kind of
search, highlight this query and click Edit Query. Click the Continuation tab of the
query form, select the desired patient, and click Run Query.

Alternate Views

Collapsed Day View

By default, the Day View shows every 15 minute interval in your defined workday
period. When you schedule an appointment across two or more 15 minute intervals,
the patient’s name appears in each of those intervals. There is an alternate collapsed
view that removes duplicates, making it easier to see what has been scheduled and
what is open.
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On the left is the
standard Day View.
On the right is the
same day shown in
the collapsed view.

You can toggle back and forth between the two views using the <F5> key, or by
selecting Collapse View on the menu. Remember that you can call up the menu with
<F2>, <Alt><M>, or by clicking the Menu button. Repeat the same steps to switch
back the other view.

Week View

You can view appointments a week at a time by selecting Week View from the
scheduler pop-up menu, or by selecting View > Week View.

The Week View shows
all seven days of the
week. Don’t forget that
you can change the
column widths by
dragging the vertical
separator lines with
your mouse.

You can use the Week View just as you would use the Day View, selecting operations
from the pop-up menu. Use the Collapse feature in Week View just as you would in
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Day View to reduce the display to show you the most information in the least amount
of space.

TIP You can re-size the columns in the Week View b y clicking and dragging the
separator (vertical line) between the columns in the view. When the mouse is
correctly positioned over a column separator it changes to a double arrow with a
vertical line in the middle. To hide days that you never schedule, use the Options
button.

You can give yourself
more room by hiding
days on which you do
not schedule appoint-
ments with the
Options button on the
Week View.

Month View

At times you may find it convenient to view the schedule a month at a time. Select
Show Month View from the pop-up menu or select View > Month View. 

Use the provider drop-list to select the desired provider. The Month View displays a
six week period. You can set the first week by clicking the Appointment Month bar.
The week you select on the pop-up calendar will become the first week of the six
weeks displayed. Use the “VCR” buttons below the Appointment Month bar to
quickly move back a year (<<), back a month (<), forward a month (>), or forward a
year (>>). 

The color coding on the calendar tells you whether the day is templated for
appointments or not. Green indicates that one or more appointments times are
templated. Red indicates that no appointment times are templated. Position the mouse
over the day to see summary information about the day’s appontments.

If you click once on a day in the Month View, you will see the appointments for that
day in the list window to the right of the calendar.

If you double-click or right-click a day in the calendar, the scheduler pop-up menu will
appear, from which you can select a different view, search, or print option.

If you double click in the appointment list window, the Day View for the selected day
will open, from which you can check, add, delete, cancel and otherwise manipulate
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appointments.

The  Month View is
actually a six-week
calendar. A green bar
indicates that there
are appointments or
open slots; red means
there are no slots.
Clicking a day shows
the appointments in
the lower right
window.

Viewing More than One Schedule

You can open several schedules, with the same or different views, at the same time.
You do not have to close the one currently open on your desktop to open another. To
open the schedule for a different provider, you must start at the top level, so select the
desired view from the Scheduler menu or the task bar. As with the first schedule
thread that you opened, you will see the provider list so that you can make your
selection. If you were to select View > Day View three times, you would end up with
three Day View windows open on the desktop. Each one is independent of the others
and can show a different provider, day, view, etc. The number of scheduler windows
that you can usefully display on your monitor at once is determined by your screen
resolution and monitor size. Realistically, a station that is used for heavy scheduling
should have at least a 17” monitor set to a resolution of  1024 x 768 or higher.
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Several schedules can
be open on the
desktop at the same
time.

Advanced Appointment Management

Creating the Same Appointment For More Than One
Provider

Let’s say that you want to schedule a meeting for several providers. Begin with Find
Meeting on the pop-up menu. Select the desired date and time range, day(s) of the
week, providers, and site (if applicable). Run Query to search the indicated schedules
to find times when all of the providers are available. 

Now that you have some acceptable times, you could open each provider’s schedule
and enter the same appointment, but there is a much faster way:

1. Open the Day or Week View.

2. Create the meeting appointment for one of the providers and save it.

3. Move the mouse pointer over the appointment and right-click. Alternatively,
select the appointment and press <F2> or click the Menu button.

4. Select Multiple Providers.

5. Click to select one or more providers.
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6. Select OK. The scheduler will create the same appointment for all the tagged
providers.

Replicating (Copying) an Appointment

A common need is to schedule the same appointment at certain intervals, for example,
every seven days for the next four weeks.

To quickly schedule a repeating appointment:

1. Enter and save the first appointment.

2. Right-click the appointment. Alternatively, select the appointment and press <F2>
or click the Menu button.

3. Select Replicate Appointment from the pop-up menu.

4. Indicate the number of appointments to create and the interval between
appointments.

5. Select OK.

Canceling and Deleting Appointments

The Scheduler differentiates between canceling an appointment and deleting an
appointment. When you cancel an appointment, you indicate the type of cancellation
and the information remains in the database, where it can be retrieved for future
reference. For example, if you wanted to see how often a particular patient cancels
appointments, you could go to Search Appointments and display all appointments
for that patient with one or more cancellation statuses. 

Normally you won’t see the canceled appointments in Day, Week, or Month View.
You can set the Show Canceled Appointments option on the pop-up menu (click
anywhere in the appointment grid, then <F2>, right-click, or <Alt><M>) if you would
like to see these appointments in Day or Week View. Canceled appointments are
followed by an asterisk (*) when displayed.

Contrast canceling appointments with deleting appointments. When you delete an
appointment, it is removed from the database and will not appear in any search results
or reports.

To cancel an appointment:

1. Right-click the desired appointment. Alternatively, select the appointment and
press <F2> or click the Menu button.

2. Select Cancel Appointment from the pop-up menu.

3. Select the appropriate Cancel Status from the drop-list.

4. Select OK.

To delete an appointment:

1. Right-click the desired appointment. Alternatively, select the appointment and
press <F2> or click the Menu button.

2. Select Delete Appointment from the pop-up menu.
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3. Confirm the deletion by selecting Yes.

Rescheduling Appointments

To reschedule an appointment:

1. Right-click the desired appointment on the Day or Week View. Alternatively,
select the appointment and press <F2> or click the Menu button.

2. Select Reschedule Appointment from the pop-up menu.

Canceling and Rescheduling

If you simply reschedule an appointment as described in the previous section, the
effect is the same as if you had deleted the appointment and then added it again on
the new date and time. Some may prefer to keep a record of the original appointment
by canceling it rather than deleting it. The scheduler’s pop-up action menu includes
an option to Cancel/Reschedule the appointment, which does both operations in a
single step.

Blocking Dates 

You can block  dates, or periods of time on certain dates, to prevent any appointments
from being added or copied to those days.  This feature is handy for marking vacation
time and other dates on which no appointments should be scheduled.

Blocked times and dates are entered on the second tab of each provider’s Templates.
There are two ways to block a date:

The first way is to enter the block from either the day view or week view:

1. Right-click the cell in the appointment grid that marks the beginning of the period
that you would like to block.

2. Select Add Block. The Add Block form will appear, the starting date and time of
the block set to match the currently selected cell in the appointment grid. 

3. Change the ending date if necessary and set the desired ending time.

4. OK to save. 

If you later would like to modify or delete the block, go to the Blocks tab of the
Lookups > Templates window to do so.

The second way is to enter the blocked periods directly on the on the Blocks tab of
the Lookups > Templates form:

1. Select Lookups > Templates.

2. Select the desired provider from the drop-list.

3. Click the second tab, Blocks, or press <Ctrl><Tab> to change to the Blocks tab.

4. Select the Add button and complete the form, specifying the starting date and
time and the ending date and time for the period to be blocked. Note that the
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entire period between the starting date and time and ending date and time will be
set as blocked. 

Set blocked dates and
time periods on the
Blocks tab of the
provider’s template
window. In this
example, the provider
is leaving an hour early
on Friday, Jan 10th,
and has blocked out a
vacation period in
June.

Quickly Finding a Patient in OMWin or CMWin
From time to time as you are creating an appointment for an existing patient, you may
have the need to access some related information in either OMWin or CMWin.
Normally doing so would require that you switch to that program (either by clicking
the appropriate button on the toolbar or by pressing <Alt><TAB> one or more times),
open the Active Patient list, type in an ID or name, and press <Tab>. There is a faster
way:

1. At the top of the Appointment Form is a lookup field to select the patient for the
current appointment. Right-click in that field, or <TAB> to that field and press
<F2>. The patient selection window shown below will appear.

2. Find and highlight the desired patient. 

3. Click the Set ID button or press <Alt><D>.

4. Switch to the either OMWin or CMWin and press <Ctrl><F> to open the Active
Patient List to the desired patient.

5. Once you have checked the desired information in the other program, switch back
to the Scheduler using <ALT><TAB> or by clicking the Scheduler button on
your Windows taskbar.
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Use the Set ID button
on the patient selec-
tion list in the Appoint-
ment Form to store the
highlighted patient’s ID
for quick access in
either OMWin or
CMWin.

Configuring and Printing Encounter Forms
Encounter forms, sometimes referred to as “superbills” are an institution in many
healthcare offices. They are used for routing, as a billing input document, as a patient
receipt, and as a patient insurance filing document. These forms contain patient
demographic and insurance information, along with a list of common services, CPT
codes, and a place to write in fees and amount received.

OMWin's encounter forms feature is available only with the Appointment Scheduler
option. Input for the report comes from the appointments entered in the scheduler.
Below is a sample of an encounter form:
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Encounter forms are customizable at two levels. The center portion of the encounter
form consists of a checklist of up to 60 services, optionally organized in sections with
headers. You determine the services, the text for each service, sections, and headings
in this portion of the form. Each of these configurations is saved as an encounter form
style, and you can create as many styles as you like. Once you have created your
styles, simply link the appropriate one to each of your providers on the Additional tab
of the Provider Form in OMWin or CMWin. When you print encounter forms, the
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Scheduler automatically selects the correct style for each provider. Information on
how to create encounter form styles appears in the next section.

The second level of customization is available to more sophisticated users who have,
and know how to use, Crystal Reports Pro. The encounter form itself is a Crystal
Reports RPT file, ENCNTR0.RPT, located in the \SOS folder. If you want to make some
changes in the header or footer of the output, you can easily do that by modifying the
RPT file and saving it under a different name, such as ENCNTR01.RPT. You can use
any number as the eighth character of the file name and the report will still run
correctly, but be sure to retain the first seven characters (ENCNTR0). The last step is
to add your customized version to the Reports menu in the Scheduler. Just right-click
in the white area of the menu box and select Add. Type in an appropriate description
and the filename of your modified report and save. The standard Encounter Form
selection will be reinstalled every time you update, so it is important to create a new
menu item with a different description, rather than changing the existing one.

Note At present, the SOS products include Crystal Reports version 8.5 runtime compo-
nents. This software can run reports created with versions 7.x through 8.5, but are not
compatible with Crystal Reports version 9 and later! If you plan do create custom
reports, make sure that you use one of the compatible versions of Crystal Reports to
do so.

Creating an Encounter Form Style

To create a new encounter form style:

1. Select Setup > Encounter Form Styles from OMWin's main menu.

2. Select Add under the list box on the left. 

3. Give your style a shorthand Code and a longer Description, then OK to save.

The next step is to set the services and headings for the style that you just created.

Adding and Changing Encounter Form Lines

Encounter form lines include service codes and descriptions, section headings, and
empty boxes. You can create a set of 60 lines for each encounter form style, with any
combination of services, headings, and blank lines.

1. Select Setup > Encounter Form Styles from Scheduler's main menu.

2. Highlight the style on the left that you want to configure or modify.

3. To add a new line item, click the Plus (+) button under the list box on the right.
(Or, using the keyboard: tab to right-side list, then press <Insert>.)

4. If you want to create a heading, check the Section heading box and enter your
heading text next to Description. If you want to enter a service line, then enter the
appropriate shorthand code for that service next to Service Code or select the
desired service from your Services List by pressing <F2> or right-clicking in that
field. When you tab to the Description field Scheduler will insert the description
for that service for you automatically. You can, if you like, modify the description
text. Select OK to save.

SOS Appointment Scheduler

- Page 26 -



5. Press <Insert> or click the Plus button to add additional section headings and
services. You can enter up to 60 lines.

6. If you would like to include blank lines as shown in the right-hand column in the
image above, enter lines without selecting a service and entering only a period (.)
as the Description.

7. To rearrange the order of the headings and services, use the
move-up/move-down buttons below the list.

8. To modify an existing item, highlight it and press the delta (? ) button beneath the
list.

Reports
The reports described below and more may be found on the Reports menu or by
clicking the Print... button on one of the pop-up menus. You may add new reports,
created by yourself, another member of your organization, or by SOS programmers.

Appointment Check-In and Confirmation Lists

The Check-In List prints all active appointments for the desired date. This report is
meant to serve as a front desk appointment sheet. It includes all providers and sorts
appointments by time.

Another version of this report, the Check-in List with Phone and Appointment Status
adds the phone numbers and appointment status for each appointment. The report
can be used in the same way as the standard Check-In List, but can also be used as a
worksheet for offices that call to confirm appointments.

Daily Provider Log

The Daily Provider Log is designed for distribution to service providers at the
beginning of the day. It contains details of each appointment, but also some
information about each patient, including primary diagnosis, current balance, and
telephone numbers. The report also has blanks next to each appointment for the
provider to write the service, fee, and any payment received. In some offices these
blocks are completed and the provider returns the sheet at the end of the day. Office
staff enter the charges and payments from the Provider Log the following day.

Appointments for Period

This report prints a summary of scheduled appointments for the specified date range
and provider and includes notes entered on each appointment form.
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Other Reports

Additional reports included with the product include the following:

w Check-in List with Phone Numbers and Status

w Appointments by Resource for Period

w Appointments for Period without Notes

w Appointments History

w Canceled Appointments

w Resource Schedule

Importing Appointments into OMWin’s Daysheet
In many cases, manual entry of charges can be greatly reduced by importing charges
directly from the appointment scheduler to the Daysheet. To enable this feature in
OMWin, select Setup > System Options, Transactions tab. Set the Import into
daysheet from option to “Scheduler”. Click OK to save.

To import appointments, open the OMWin Daysheet window, then select the Import
Appointments button. Specify the date range and, if desired, specify a particular
provider. If no provider is specified, then all will be imported.

A list window containing all the specified appointments will appear. By default, all are
tagged for import. If there are any you do not wish to import, simply untag them.
When you are ready to continue, select the OK button.

As the appointments are being imported, OMWin examines them to be sure that the
system has enough information to create a complete charge. If it does not, then it will
display the normal charge entry window so that you can complete the entry.

After import, the new entries will appear in the Daysheet where you can view, change,
or delete them as necessary. Note that you can import appointments only for existing
patients. 
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